RubyのRSS Parserをアップデートする

動作確認のために時々アップデートしておきませう。

環境

RubyのRSS Parserをアップデートする

追加でインストールした既存のRSS Parserを削除してから新しくインストールする。

$ pwd
/home/username/opt/ruby/lib/ruby/site_ruby/1.8

$ rm rss.rb
$ rm -fr rss

$ $HOME/opt/ruby/bin/irb
irb(main):001:0> require 'rss'
=> true
irb(main):002:0> p RSS::VERSION
"0.1.6"
=> nil
irb(main):003:0> exit

$ pwd
/home/username/src

$ wget http://www.cozmixng.org/~kou/download/rss-0.2.0.tar.gz

$ tar zxf rss-0.2.0.tar.gz

$ pwd
/home/username/src/rss-0.2.0

$ $HOME/opt/ruby/bin/ruby setup.rb

$ $HOME/opt/ruby/bin/irb
irb(main):001:0> require 'rss'
=> true
irb(main):002:0> p RSS::VERSION
"0.2.0"
=> nil
irb(main):003:0> exit
    

関連情報

2007, AfternoonTea